Special Ops Paintball: SP-1 Front Grip - Special Ops Paintball

Jump to content


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

SP-1 Front Grip Help!

#1 User is offline   Minnesota Sn1p3r 

  • Back on the Attack!
  • PipPipPip
  • Group: Members
  • Posts: 363
  • Joined: 26-September 08
  • Gender:Male
  • Location:New Market, MN
  • Brigade Name:MN Sn1p3r

Post icon  Posted 16 September 2009 - 04:33 PM

I took everything apart so I could get my trigger out. When I put it all back together, my front grip was loose. Now, when I try to tighten it, it makes a ginding noise.

If you have any Ideas of what could be wrong, PLEASE HELP!!! :excl:
"Its better to out-think your enemy than to out-fight them" - Sun Tzu

"I dont like paying for the same realestate twice" - General George S. Patton
0

#2 User is offline   -SMITTY- 

  • one of the original 27,731 members
  • PipPipPipPipPip
  • Group: Members
  • Posts: 1,123
  • Joined: 20-January 07
  • Gender:Male
  • Location:You know Westfield MA? Nowhere near there. ;)
  • Brigade Name:-SMITTY-

Posted 16 September 2009 - 05:22 PM

sounds like the threading is a little messed up, or theres some dirt on the threads
0

#3 User is offline   Cuy'val Dar  

  • 327 G.I.R. Bastogne Bulldogs
  • PipPipPipPip
  • Group: Members
  • Posts: 759
  • Joined: 31-May 09
  • Gender:Male
  • Location:Ponchatoula Louisiana
  • Brigade Name:MICHAEL J. CABOOSE

Posted 16 September 2009 - 06:41 PM

use a moist q-tip to clean the threads. thats what my friend did when he got dirt in em, and no more problem. also, you might try to lube it a little.
Posted Image

Doorbells? Seriously? That's the swear filter?
. -Pirate
"Authenticity bro, everyone voids their bowels when they die."
-Guy at end of paintball movie
0

#4 User is offline   danthegreat666 

  • Forum Newbie
  • Pip
  • Group: Members
  • Posts: 10
  • Joined: 22-April 09
  • Brigade Name:Zidan

Posted 20 September 2009 - 10:15 PM

View PostMinnesota Sn1p3r, on Sep 16 2009, 07:33 PM, said:

I took everything apart so I could get my trigger out. When I put it all back together, my front grip was loose. Now, when I try to tighten it, it makes a ginding noise.

If you have any Ideas of what could be wrong, PLEASE HELP!!! :excl:

Sounds like your stripping it :D
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users